Introduction to MATLAB


1. Introduction to MATLAB

1.1 What is MATLAB?

 MATLAB is an interactive system for technical computing integrates computation, visualization, and programming where problems and solutions are expressed in familiar mathematical notation. It allows you to solve many technical computing problems, especially those with matrix and vector formulations. The operations in MATLAB are designed to be as natural as possible. Typical uses include: Math and computation, data acquisition, modeling, simulation, and so on. In university environments, it is the standard instructional tool for introductory and advanced courses in mathematics, engineering, and science.

The basic data element is an array that does not require dimensioning. The matrix is a rectangular array of numbers, but not all arrays are a matrix. Special meaning is sometimes attached to 1-by-1 matrices, which are scalars, and to matrices with only one row or column, which are vectors.

Note: MATLAB has other ways of storing both numeric and nonnumeric data, but in the beginning, it is usually best to think of everything as a matrix.

You can enter matrices into MATLAB in several different ways: Enter an explicit list of elements, create matrices with your own functions in M-files or generate matrices using built-in functions, load matrices from external data files. Start by entering matrix as a list of its elements. You only have to follow a few basic conventions:

· Surround the entire list of elements with square brackets, [ ].

· Use a semicolon, ; , to indicate the end of each row.

· Separate the elements of a row with blanks or commas.

To enter a matrix, simply type in the Command Window

A=[16 3 2;5 10 11;9 6 7]

MATLAB displays the matrix you just entered:

A = 

    16     3     2 

     5    10    11

     9     6     7 

Once you have entered the matrix, it is automatically remembered in  MATLAB workspace. You can refer to it simply as A. 

You can enter a matrix using variables instead of numbers, but these variables must be defined first. If  MATLAB workspace contains the b11, b12, b21, b22 variables and the actual values these variables: b11=3.2, b12=-5, b21=1.7 b22=3, than you type in the Command Window

B=[b11 b12;b21 b22]

MATLAB displays the matrix you just entered:

B = 

    3.2   -5  

    1.7   3 

Note: Hungary the comma is used instead of point to sign the decimal notation. You have already seen commas separate the element of a row. Using the comma instead of point you make a syntax error or unfortunately you create another matrix.

1.2 Expressions.

The names of variables and files are case sensitive. The names may contain big and small letters of English alphabet and numbers. Only the, _ , character is allowed.  

Note: It is very important that the variable’s names mustn’t contain character of other languages, space, comma, and so on! 

The names of the variables always belong to actual value or values. The actual value of the variables is stored. All numbers are stored internally using the long format specified by the IEEE® floating-point standard. 

MATLAB uses conventional decimal notation, with an optional decimal point and leading plus or minus sign, for numbers. 

3              -99            0.0001

Scientific notation uses the letter e to specify a power-of-ten scale factor. 

9.6397238      1.60210e-20    6.02252e23

Imaginary numbers use either i or j as a suffix. Some examples of legal numbers are

2.1+6.54i      -1-3.5j        4.2e-3.4

1i             -3.14159j      3e5i

Expressions use familiar arithmetic operators and precedence rules. 

· Addition 

+

· Subtraction 

–

· Multiplication 
*

· Division 

/

· Left division 

\

· Power 


^

· Complex conjugate 
‘

Arithmetic operations on arrays are done element by element. The addition and subtraction are the same for arrays and matrices, but those multiplicative operations are different. MATLAB uses dot, or decimal point, as part of the notation for multiplicative array operations. Element-by-element multiplication .*, element-by-element division ./, and so on.

MATLAB provides a large number of standard elementary mathematical functions, including abs, sqrt, exp, and so on. Variables of functions are in parentheses. For example if you type in the Command Window

abs(-2+3i)

MATLAB displays the result you just entered:

ans

    3.6056

If you want to know how much gain is equal -14.2 dB you type in the Command Window

K=10^(-14.2/20)

MATLAB displays the result you just entered:

K=

    0.1950

If you want to use for example only the second row of the A matrix, you type the next:

A(2,:)

MATLAB displays the vector you just entered:

ans =

     5    10    11

Of course you can give a name this second row typing a2r=A(2,:) command or you can select for example the first column typing A(:,1) command.

a2r=A(2,:)

MATLAB displays the vector you just entered:

a2r =

     5    10    11

MATLAB has two transpose operators. The apostrophe operator performs a complex conjugate transposition. It flips a matrix about its main diagonal, and also changes the sign of the imaginary component of any complex elements of the matrix. Dot-apostrophe operator transposes without affecting the sign of complex elements. For matrices containing all real elements, both operators return the same result.

C=B’

MATLAB displays the vector you just entered:

ans =

    3.2   1.7  

    -5    3 

If you want to use the second row of the A matrix, such as column vector you type A(2,:)’ command.

A(2,:)’

MATLAB displays the vector you just entered:

ans =

     5

    10

    11

The colon : is one of the most important MATLAB operators. It occurs in several different forms. The expression 1:10 is a row vector containing the integers from 1 to 10. To obtain non-unit spacing, specify an increment. 

Note: At the end of the command line using  semicolon ; operator the results is counted, but not displayed in the Command window.

Defining a y(x) function is very easy with the colon operator. 

x=0:0.25:10;

y=cos(x);

After entering two row vector x and y will be in the Workspace.

The MATLAB software provides some functions that generate basic matrices. Some examples:

D=zeros(2,4)

ans =

  0  0  0  0

  0  0  0  0 

E=3*ones(3,2)

ans =

  3  3 

  3  0 

  3  3 

With the left mouse button click on the variables’ name at the Working space area and a table appears containing the values of the variable. You can overwrite these values.

1.3 About the Desktop.

When you start MATLAB program, in general the desktop appears with the default layout. You can change the desktop arrangement to meet your needs, including resizing, moving, and closing tools. You can restore the default layout, as shown in the following illustration.
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Figure 1.1. Default layout of MATLAB desktop

Desktop tools

Command Window: Run MATLAB language statements. The Command Window prompt, >>, is where you enter statements. For example, you can enter a MATLAB function with arguments, or assign values to variables. The prompt indicates MATLAB is ready to accept input from you. It is possible to navigate the previously used statements with ↑ up arrow and ↓ down arrow buttons. If you want to use the previously statement just push the ↑ up arrow button and the previously statement appears you can modify it. 

Command History: View a log of or search for the statements you entered in the Command Window, copy them, execute them, and more. The Command History window lists statements you ran in the current session and in previous sessions. The time and date for each session appear at the top of the history of statements for that session. Select an entry or entries and then select Copy from the context menu. Paste the selection into an M file or the Command Window. Double-click an entry (entries) in the Command History window to execute the statement(s) in the entries.

Current Directory: View files, perform file operations such as open, find files and file content, and manage and tune your files.

Workspace: View and make changes to the contents of the workspace. You can directly edit variable values in the Workspace browser Value column. To edit a value, position the pointer in the Value column at the row you want to edit, click, and type the new value. To view more of the data for a variable, as well as to more easily edit it, double-click a variable name and it opens in the Variable Editor.

Editor: Create, edit, debug, and analyze M-files (files containing MATLAB language statements). See details later.

Figures: Create, modify, view, and print figures generated with MATLAB. See details later. 

Editor

You can create a new blank or prepopulated file in the Editor. A prepopulated file provides elements typically included in the file type you choose to open. 

The most popular file type the M file. To create an empty M-file, choose File > New, and then choose M file. Alternatively, to create an empty M-file in the Editor, click the New M-File button on the MATLAB desktop toolbar. The Editor opens (Figure 2.) an untitled file in the MATLAB current directory.

You can comment lines putting the „%” character in at the beginning of the current line or make a selection of lines in an M-file and select Comment from the Text menu or right-click and the selected lines become comment.

In the Editor, to run a script M-file, or a function M-file that requires no input arguments, click the Run button on the toolbar. The button's ToolTip includes the name of the file to be run, which is useful when you have multiple files open. Alternatively, select Debug > Run file name. 

An asterisk (*) follows the file name in the title bar of the Editor after making changes to a file. This indicates there are unsaved changes to the file. If the file is newly created, the Save file as dialog box opens, where you assign a name to the file before saving it. Another way to save is by clicking the Save button on the toolbar. 

If the file has unsaved changes, running it from the Editor automatically saves the changes before running. In that event, the Debug menu item is Save File and Run file name.
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Figure 1.2. Editor layout 

The line and column numbers for the current cursor position of the cursor in the text are shown in the far right side of the status bar in the Editor. It’s useful when the debugger interrupts the M file’s running and an error message appears in the Command Window containing these parameters.

1.4 Figure.

The MATLAB environment offers a variety of data plotting functions plus a set of GUI (Graphic Unit Interface) tools to create, and modify graphic displays. The figure GUI tools afford most of the control over graphic properties and options. A figure is a MATLAB window that contains graphic displays (usually data plots) and UI components.

You create figure window explicitly typing the figure function in the Command Window, and implicitly whenever you plot graphics with activated an function such as step, bode, plot, and so on. Generally you will use the implicitly way, because there are some very useful added facilities to the Figure window GUI depending on the called function. For example:

x=0:0.1:15;

y=sin(x)./sqrt(x+1);

plot(x,y)

Note: Without the semicolon ; operator at the end of lines the elements of the x and y variables are written on the Command window surface.

The Figure window appears and represents the result.
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Figure 1.3. Figure window 

You can collect together some curve in the same Figure window. Different colors distinguish the curves (Figure 1.4). 

You can arrange the results an array and all row this array containing the elements of the associated curve. Array y(n,m) variables for the results:

x=0:0.1:15;

y(1,:)=sin(x)./sqrt(x+1);

y(2,:)=sin(x/2)./sqrt(x+1);

y(3,:)=sin(x/3)./sqrt(x+1);

plot(x,y)

You can give an independent name all curves and these names represent a row vector containing the elements of the curve. Independent y1, y2, y3 variables for the results: The both method’s result is the same (Figure 1.4).

x=0:0.1:15;

y1=sin(x)./sqrt(x+1);

y2=sin(x/2)./sqrt(x+1);

y3=sin(x/3)./sqrt(x+1);

plot(x,y1,x,y2,x,y3)
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Figure 1.4. Some curve together in the Figure window

Edit Figure

Figure toolbars provide shortcuts to access commonly used features. These include operations such as saving and printing, plus tools for interactive zooming, panning, rotating, querying, and editing plots. The following picture shows the features available from this toolbar.
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Figure 1.5. Figure toolbar

There are two ways to activate Plot edit mode. Either choose the Edit Plot option on the Figure window’s Tool menu, or click the Arrow button in the Figure window toolbar. After activating Plot edit mode you can choose an option of Edit or Insert menu. Some of this option appearance in a new icon line activating the Plot Edit Toolbar in the View menu (Figure 1.6).
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Figure 1.6. Edit Figure

There are some possibilities to edit the Figure window or the curves:

· Using the Insert menu or the Plot Edit Toolbar you can put on the picture Line, Text Arrow, Text Box, and so on. 

· You can give a label for the axes and change all properties of the signed curve with the Property Editor at the View menu. The dialog box of Property Editor also appears with double click on the picture.
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Figure 1.7. Property Editor

· Left mouse click on an object selects it. After this you can modify for example the context of the Text Box or change the position of a Line.

· You can change the position of labels, legends, or other objects by clicking and dragging.

· Right mouse click on the selected object offers you a pop up menu with object specific plot edit functions (Figure 1.6).

· And so on!

To exit the Plot edit mode click again the Arrow button in the Figure window toolbar or deactivate the Edit Plot option on the Figure window’s Tool menu.

Data cursor

Data Cursors enable you to read data directly from the graph. You can activate the Data Cursor selecting the Data Cursor item in the Tool menu or click the Data Cursor icon in the Figure toolbar (Figure 1.9).

When the Data Cursor mode is enabled:

· You can display a data-tip text box with the values (x, y, and z if 3-D) of the nearest data point by clicking on any graphic objects. You can position the data-tip text box press but not release data-tip text box while moving it.

· You can export the data values of a selected point as a Workspace variable with a right mouse click on the selected object and choosing the Export Cursor Data to Workspace item. First you must define the variable’s name.

[image: image8.png]Enter the variable name





Figure 1.8. Export data

· You can display multiply data-tip text box choosing the Create New Data-tip item in the previous pop up menu (Figure 1.9).

· You can display delete the current or all data-tip text box selecting the graphic object and right mouse click (Figure 1.9). 

· Selecting the graphic object and right mouse click you can choose the Selection Style and after the Mouse Position items (Figure 1.8). With this option you can display the interpolated Data-tip’s values between two data points.
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Figure 1.9. Data Cursor

1.5 SIMULINK

MATLAB has a lot of Tools for specific application. SIMULINK provides tools to model and simulate the almost any real-word problem. SIMULINK is a GUI (Graphical Unit Interface) for building model as a block diagrams. It includes a block library of sinks, sources, linear and non-linear components, and connectors.

For example there is a closed-loop system model:
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Figure 1.10. SIMULINK model of a closed-loop system

On the figure above the green part is a PIDT1the controller in details, the blue part is a process model with actuator, plant, and transmitter, the orange part is unit step sources, and the yellow part put the post-processing result to the Workspace and visualization.

SIMULINK software requires MATLAB to run!
Menus are depending on the tool you are using. 
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